Skip to main content

Correzione "Visual Studio 2005 SP1 richiede un aggiornamento per Windows Vista"

Correzione "Visual Studio 2005 SP1 richiede un aggiornamento per Windows Vista"

Geoffrey Carr

Avevo sentito che Visual Studio 2005 ha problemi di compatibilità con Windows Vista, quindi non sono stato sorpreso quando ho ricevuto questo messaggio di errore quando cercavo di eseguire per la prima volta. Per risolvere questo particolare messaggio di errore, è necessario installare l'aggiornamento SP1, che è praticamente il service pack per il service pack, credo.

È possibile scaricare l'aggiornamento SP1 qui: http://go.microsoft.com/?linkid=6366078

Dopo aver installato l'aggiornamento, ho ricevuto questo messaggio di errore che diceva "Le autorizzazioni di amministratore sono consigliate per l'esecuzione di Visual Studio 2005 SP1" e chiede di utilizzare l'opzione Esegui come amministratore all'avvio di Visual Studio.

Dopo aver fatto qualche ricerca, hai un paio di opzioni:

  • Esegui Visual Studio come amministratore (la soluzione migliore è cambiare semplicemente il collegamento per eseguire sempre l'amministratore.) In questo modo si finiranno comunque con alcuni errori.
  • Eseguire Visual Studio come utente normale e aprirlo come amministratore solo se si verifica un errore specifico che richiede l'accesso di amministratore.
  • Basta deselezionare la casella.

Suggerimento: se si sta tentando di eseguire il debug di progetti Web, è necessario assicurarsi di accedere a Aggiungi / Rimuovi componenti di Windows nel Pannello di controllo e installare la compatibilità IIS6 con l'opzione IIS7, altrimenti non si avrà molta fortuna.

Nel complesso, Visual Studio 2005 non è molto compatibile con Vista. È frustrante, ma è la vita.

Link
Plus
Send
Send
Pin